Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cache Standard Interface #17

Closed
wants to merge 71 commits into from
Closed

Cache Standard Interface #17

wants to merge 71 commits into from

Conversation

tedivm
Copy link
Contributor

@tedivm tedivm commented Mar 11, 2012

Proposed is a set of interfaces for a basic cache system, as well as extensions that can be used to build upon it. The goal of this PSR is to allow developers to create cache-aware libraries that can be integrated into existing frameworks and systems without the need for custom development.

Conversation has occurred on the list with regards to this, but additional discussion and PR's is highly encouraged.

tedivm and others added 30 commits February 25, 2012 01:21
This is the initial outline of the caching proposal, including the
interfaces themselves (which are the most fleshed out part of this
being added to the repo at the moment).
This will allow people to actually use the interfaces.
Changed some of the formatting around, added the "Multiple" section.
Extensively expanded the proposal. Added the new interfaces (with
comments), wrote out the introduction and data sections, and cleaned up
a lot of formatting.
Clarified that the clear function should return true as long as the
item is not in the cache at the end of the call, regardless of whether
it was removed or never existed.
Clarified acceptable keys, clarified that null should explicitly be
null, altered header names, added text for namespaces, added the
TaggableItem interface, and removed the driver interface.
By merging the two classes into one we create more of an environment
class, which makes certain extensions significantly easier to architect
simply.
Ran through and made sure all class names were correct and fixed some
misspellings. Cleaned up the interfaces a bit, and then brought their
new comments back into the main proposal.
php opening tags for syntax highlight
norv and others added 11 commits May 27, 2012 23:08
php tags in Extensions interfaces.
This was brought up on the mailing list and seemed like a reasonable
idea. It also will make it easier for implementing libraries to use one
class for systems that use stackable and non-stackable components,
making it easier to segment the two pools (internal namespacing or
something) as there will *always* be a slash when Stackables are used.
Updated the Stackable keys to have them start with a root slash.
Clarification on Item::set()
…che"

As discussed on the mailing list, there may be some confusion over the
"getCache" and "getCacheIterator" functions since there is no actual
cache object. By changing them to "getItem" and "getItemIterator" we
make it much more clear what is actually returned.
Updated the names of the "get" functions to use "Item" instead of "Cache"
*
* @return bool
*/
function isMiss();
Copy link

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Almost all validators I've seen pass with a positive result, so I'd prefer to see this as isValid, isAvailable, etc.

Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

+1 : if (! isMiss) is less readable than if (! isAvailable) (avoid double negatives)

Copy link

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

BTW I realize that you chose isMiss because most checks would be testing for a fail before regenerating the cached value, but I still think it looks funny in the interface.

Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I'm in agreement here. The isValid() or isAvailable() are much closer to what I'd expect from the proposal. @tedivm can you please update your PR to make this a true check rather than a false check?

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Is here a preference? I'm thinking "isValid" is better than "isAvailable".

Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

how about exists()?

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I'm not a big fan of exists, as whether an item exists or is valid are really two separate questions. The "get" function may be able to return a value that exists, but is past it's ttl and therefore no longer valid, at which point the developers using the library needs to make a decision about what they'd like to do. In most cases they'll treat validity and existence as the same, but that won't always be the case.

Copy link
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

Well if it's expired IMO it shouldn't exist anymore, it should be a
cache miss.

Copy link
Member

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

IMO it shouldn't be possible to get a cache entry that expired.
Edit: I agree with @Seldaek

Copy link
Contributor Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

90% of the time you're right, but I don't think we should exclude the 10% time when it's reasonable. There are many, many cases where it's more valuable to use a stale value (presumably while another process is regenerating the proper value), rather than enter a stampede (aka the dog pile affect) or pause to wait for the value to return.

Keep in mind this isn't saying get has to return anything- it doesn't. What this is saying is that the option is there for a library to expand it's functionality within the scope of this proposal. If a library wants to have a "standard" Pool and Item class, but also wants an extended Item class that handles validation differently (such as by doing any of the following- http://stash.tedivm.com/Invalidation.html ) then this standard should not get in their way.

The extensions were removed so the focus could be on the core standard.
Should this standard pass they'll be brought up for discussion and vote
on their own.
@nfx
Copy link

nfx commented Dec 6, 2012

Shall we include Compare-And-Swap concept? http://neopythonic.blogspot.nl/2011/08/compare-and-set-in-memcache.html

tedivm and others added 12 commits February 25, 2013 18:41
Accidentally tossed an old PSR in here when merging with the main
fig-standards branch.
This was based off of Paul's suggestion in the mailing list, and tries
to make the function call more intuitive.
This change was made to provide clarity, as some libraries use "flush"
to mean "save changes" which is pretty much the opposite of what's
happening here.
Added "Key Concepts" section to help explain naming conventions.
Value should be able to be set to null.
Use clear instead of empty as empty is a reserved word.
@philsturgeon
Copy link
Contributor

This proposal has been superseded by #96. Please continue discussion over on the mailing list topic.

dragoonis pushed a commit that referenced this pull request Jul 11, 2014
samdark pushed a commit that referenced this pull request Oct 18, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

Successfully merging this pull request may close these issues.