Description
In the whole codebase, there is a standard which is to include the suffix in_place
on operations which modify the value passed as a mutable parameter. For example here:
algebra/ec/src/models/bn/g2.rs
Lines 53 to 77 in cc2ad8c
We know from the function name that the self
mutable will be modified.
However similar operations are performed in the BigInteger
trait like:
algebra/ff/src/biginteger/mod.rs
Line 1062 in cc2ad8c
or
algebra/ff/src/biginteger/mod.rs
Line 1037 in cc2ad8c
without including the in_place
suffix. For readability and consistency, it could be nice to include this suffix for all the BigInteger
operations concerned by this type of logic.