Open
Description
Summary
- We could rename these to
B512
fromBits512
to better align with the wider ecosystem. - We're missing documentation on how to form a B512, from two B256.
- I think the example of just using the wallet public key could be changed to show how to form this with two b256.
- We could also improve the Sway example with a more complex use-case, rather than just echoing out the response.
- The Rust SDK are using the B512::from function (here) and I was unclear how to imitate this with the TS SDK. (this could be a feature request)