http://hg.honeyplanet.jp/libavcore.hg/ libavcore.hg Changelog 2010-09-08T23:36:14+00:00 [libavcore] av_fill_image_linesizes -> av_image_fill_linesizes http://hg.honeyplanet.jp/libavcore.hg/#changeset-ed20007aabe20076d29a8eb7eb9e1af5d6bdb66b ramiro ramiro 2010-09-08T23:36:14+00:00 2010-09-08T23:36:14+00:00
changeset ed20007aabe2
branch libavcore
bookmark
tag tip
user ramiro
description av_fill_image_linesizes -> av_image_fill_linesizes
files imgutils.h
[libavcore] Add missing checks on invalid pixel format in http://hg.honeyplanet.jp/libavcore.hg/#changeset-ec642b5a1d0aa875b71212d8cb057b4d112ed725 stefano stefano 2010-09-07T23:41:18+00:00 2010-09-07T23:41:18+00:00
changeset ec642b5a1d0a
branch libavcore
bookmark
tag
user stefano
description Add missing checks on invalid pixel format in
av_image_fill_linesizes/pointers.
files imgutils.c
[libavcore] Cosmetics: use plural form for *linesizes arguments of http://hg.honeyplanet.jp/libavcore.hg/#changeset-63d8168fa16a044051c3dca97f62cf86daa10f41 stefano stefano 2010-09-07T21:24:06+00:00 2010-09-07T21:24:06+00:00
changeset 63d8168fa16a
branch libavcore
bookmark
tag
user stefano
description Cosmetics: use plural form for *linesizes arguments of
av_image_copy(), more consistent with the rest of the API and more
semantically correct.
files imgutils.c
imgutils.h
[libavcore] Move av_picture_data_copy() to libavcore, and rename it http://hg.honeyplanet.jp/libavcore.hg/#changeset-c063c88b1309e5699f2f9abb1ee07256f6d42a37 stefano stefano 2010-09-07T21:23:55+00:00 2010-09-07T21:23:55+00:00
changeset c063c88b1309
branch libavcore
bookmark
tag
user stefano
description Move av_picture_data_copy() to libavcore, and rename it
av_image_copy().
files avcore.h
imgutils.c
imgutils.h
[libavcore] Reimplement ff_img_copy_plane() as av_image_copy_plane() in libavcore, http://hg.honeyplanet.jp/libavcore.hg/#changeset-478992775cf83dd5ddaca1c48833d75e8c09e17d stefano stefano 2010-09-07T21:23:45+00:00 2010-09-07T21:23:45+00:00
changeset 478992775cf8
branch libavcore
bookmark
tag
user stefano
description Reimplement ff_img_copy_plane() as av_image_copy_plane() in libavcore,
and deprecate the old function.
files avcore.h
imgutils.c
imgutils.h
[libavcore] Adopt a hierarchical name scheme for the imgutils.h API. Simplify http://hg.honeyplanet.jp/libavcore.hg/#changeset-0899fc09d43cf11d4cb88215508093998296c28a stefano stefano 2010-09-07T19:15:17+00:00 2010-09-07T19:15:17+00:00
changeset 0899fc09d43c
branch libavcore
bookmark
tag
user stefano
description Adopt a hierarchical name scheme for the imgutils.h API. Simplify
grepping and somewhat more consistent with the scheme adopted by other
FFmpeg modules API.
files avcore.h
imgutils.c
imgutils.h
[libavcore] Make av_fill_image_max_pixsteps() non static non inline. http://hg.honeyplanet.jp/libavcore.hg/#changeset-3b8eec1cfdaa2c0078c40f108d847c9e5067ccf9 stefano stefano 2010-09-06T21:51:20+00:00 2010-09-06T21:51:20+00:00
changeset 3b8eec1cfdaa
branch libavcore
bookmark
tag
user stefano
description Make av_fill_image_max_pixsteps() non static non inline.
files imgutils.c
imgutils.h
[libavcore] Use quotes instead of angle brackets for local #includes. http://hg.honeyplanet.jp/libavcore.hg/#changeset-8a62c1403cd00abb03accc95e51bc46a5b09f5d9 diego diego 2010-09-01T02:12:03+00:00 2010-09-01T02:12:03+00:00
changeset 8a62c1403cd0
branch libavcore
bookmark
tag
user diego
description Use quotes instead of angle brackets for local #includes.
files avcore.h
parseutils.h
[libavcore] Cosmetics: if( -> if (. http://hg.honeyplanet.jp/libavcore.hg/#changeset-cee2ee2eff815efdaee4384b79d92d6b8bafe89f stefano stefano 2010-08-21T15:18:52+00:00 2010-08-21T15:18:52+00:00
changeset cee2ee2eff81
branch libavcore
bookmark
tag
user stefano
description Cosmetics: if( -> if (.
files imgutils.c
[libavcore] Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps(). http://hg.honeyplanet.jp/libavcore.hg/#changeset-ebe3b7ce4cca350c74a15f67b73e7c4f0e5761aa stefano stefano 2010-08-20T16:52:38+00:00 2010-08-20T16:52:38+00:00
changeset ebe3b7ce4cca
branch libavcore
bookmark
tag
user stefano
description Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().

The plural form is preferred as it is more consistent with the other functions:
av_fill_image_linesizes()
av_fill_image_pointers()

and looks semantically more correct as it fills an array of elements.
files avcore.h
imgutils.c
imgutils.h